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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

* Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

° On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter’ means to
press the key labeled Enter.

« |talic type is used for the following:
° Emphasis.
° The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

* The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

« The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

* The menu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

* Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:
« [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.
* [product name] Scripting Help - opens the contents of the Scripting Guide.

» [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction

This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to:

» Use Icepak's QFN toolkit to create a QFN package.

» Use the Extract Delphi Network to generate a Delphi-like Surrogate Thermal Model (STM)
3D component, which can be used to replace a detailed thermal model (DTM) in a system-
level design to reduce mesh size and simulation duration, while yielding accurate thermal

results.
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2 - Create the Project

1. On the Desktop ribbon tab, click Icepak to insert an Icepak design.

2. From the File menu, select Save As, and save the project in the desired working dir-
ectory.

Set 3D Ul Options

Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View > Options.
The 3D Ul Options dialog box appears.
2. Ensure that Enable Legacy View Orientation is enabled:

30 Ul Opticns >

General | 3D Modeler Graphics |

[ Stereomode  (Affects only the newly created windows)
I Drag Optimization
[+ Show Ansys logo

Default Color Key height ] (Maximum number of values
=i eyheig B displayed)

When there is a selection

[+ Selection always visible

[+ Settransparency of selected objects Ir
[+ Settransparency of non-selected objects IF

Default Rotation About

~ ModelCenter  (~ Current Axis

(& ScreenCenter ( Cursor
Middle Mouse Bution Drag
@ Rotate " Pan  Zoom
Gradual View Change
[+ Animate
Animation Duration
R 500 msecs

[v Enable Legacy View Orientation |

OK | Cancel

3. Click OK.

Create the Project 2-1
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3 - Create a QFN Package

Use the QFN toolkit to generate QFN package geometry to serve as the basis for Delphi network
extraction.

1. From the Icepak menu, select Toolkit > Geometry > Packages > QFN.

= OFN - [m] B

L:..'III:I:'-IDI'HG: Leads Dia Bondwire

e QFNT Plane: XY

Location L
= s mn : L OoOononn A4
A
¥s % 1.1 T G
z5 0o T
Size | X -
xbength (x) 70 mm
-
yLength (y) 70 mm
Package Thickness (H): 0.9 mm
Aar Gap Under Package XS
Aar Gap thickness (G) 003 mm ) Y
Air Gap Under Package Material Air-solid
Maold
Matenal ! M W
alena; Mold_malenal v
Create 3D Component Fix Values v
Ok Lise Default Adjust Values: Cancel Hedp

2. Inthe QFN dialog box, review the default settings on the Dimensions, Leads, Die, and
Bondwire tabs.

Create a QFN Package 3-1
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Extract Delphi Network

3. Click OK to generate the package based on the default settings.

Create a QFN Package 3-2
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Extract Delphi Network

4 - Run the Extract Delphi Network
Toolkit

Run the Extract Delphi Network toolkit to create network geometry, generate training data, and
use the data to optimize the Delphi-like Surrogate Thermal Model (STM).

» Extract the Geometry
¢ Generate the Data
¢ Optimize the STM

Extract the Geometry

Use the Extract Delphi Network toolkit's ExtractGeometries tab to add network face geometry
to the model.

1. From the Icepak menu, select Toolkit > Modeling > IC Packages > ExtractDelphiNet-
work.

Run the Extract Delphi Network Toolkit 4-1
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2.

@ ExtractDelphiNetwork — a X
ExtractGeometries GenerateData OptimizeSTM
Package Type
O BGA
() aFp

O OFN

ect Internal Fac

[}
m

ternal Faces Se

LA
m

() Generic ect

Sources

Thermal Object: y Add to Sources

QFN1_DieSource

Extract Geometries

In the ExtractDelphiNetwork dialog box under Package Type, select QFN.

Run the Extract Delphi Network Toolkit 4-2
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Extract Delphi Network

3. Click Extract Geometries to generate the generate the network faces. When geometry
extraction is complete, the Extract Geometries button appears green and the faces are
displayed in the 3D Modeler window and history tree.

2-gp Model
ca% QFN1_Group
----9 Solids
é----l?' Sheets

8- Unassigned
@M=l Bottom_inner
m=} Bottom_outer
N= Sides X 0
=] Sides X 1
¥=l Sides Y 0
=l Sides Y 1
=l Top_inner
=) Top_outer
-1, Coordinate Systems
=& Planes
=62 Lists

e T e IO e OOOORY e JOUOOO oy OO e IO
il il o I el gl RS

4. Click the GenerateData tab.

Generate the Data

Use the Extract Delphi Network toolkit's GenerateData tab to create and run parametric trials.
Data from the trials will be used for the training and test data during STM optimization.
1. Onthe GenerateData tab under Parametrics, click Add New.

2. Inthe New Parametric Setup Editor dialog box under Parametric Setup, select Pre-
defined for the Parametric Origin.

3. Under Predefined, select Delphi for the Reference.
4. Retain the other default settings and click Add Setup.

Run the Extract Delphi Network Toolkit 4-3
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5. Repeat steps 1 through 4, selecting JEDEC for the predefined Reference.

ﬁj ExtractDelphiNetwork — O X
ExtractGeometries GenerateData QOptimizeSTM
Parametrics
Delphi.csv (SteadyState)

Uedec.csv (SteadyState)

Settings

Max No. of lterations: 1000

Energy: 1e-13

Mesh Settings

(] Auto Adjustment

HPC Setup

Tasks: 8 = @ Enable two level

Distributed Solutions at First Level: 4 =

Generate Data

6. Click Generate Data.
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Optimize the STM

Use the Extract Delphi Network's toolkit's OptimizeSTM tab to generate a 3D component of the
optimized STM.
1. Onthe OptimizeSTM tab under Data Files next to Training, click Add File.

2. Inthe Select Training File dialog box, browse in your working directory select the training
data file and click Open.

Note: The training and testing data is saved comma-separated value (.csv) files
appended with"_monitors" (steady-state) or " _aedtexport" (transient) at the end
of the file name.

3. Inthe Select Validation File dialog box, browse in your working directory select the test-
ing data file and click Open.

Run the Extract Delphi Network Toolkit 4-5
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4. Under Data Files next to Test, click Add File.

# ExtractDelphiNetwork — O X
ExtractGeometries GenerateData OptimizeSTM

Data Files
Training: Add File

C:\AQFN_|cepakDesign1_Delphi_SteadyState_monitors.csv [SteadyState]

Test: . AddFile

CA\LANQFN_|cepakDesign1_ledec_SteadyState_2_monitors.csv [SteadyState]

Graph Nodes

Real Nodes Settings: External Internal

Mo. of Fict. Internal Nodes: 0

Parameters Initialization

Add File
Optimizer
Algorthm: Differential Evolutionary Settings
Optimize 5TM Query STM Export STM

5. Under Graph Nodes next to External Nodes, click Settings.

Run the Extract Delphi Network Toolkit 4-6
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6. Inthe Node Selection dialog box, select each face group and select Group-specific for
Approach under Approach Settings.

E‘ Mode Selection - a e
Approach Settings
Groups

side Group: bot_out
Approach: Group-Specific

top_in Approach: Group-Specific
Approach: Group-Specific

bot_in
Approach: Group-Specific

top_out
Approach: Group-Specific

bot_out
Approach: Group-Specific

QK

7. Click OK to close the Node Selection dialog box.
8. Retain the other default settings and click Optimize STM to generate training results.
9. Click Export to open the STM Querying Settings dialog box.

10. Under Select STM, click Browse and select the folder in which to create the
3D component of the optimized STM.

11. Retain the .a3dcomp file format for the STM and click OK to generate it.

Review the Training Results

In the training files directory, open the .png image file appended with "_error_bars" to view the
temperature mean and max temperature error percentage.

Run the Extract Delphi Network Toolkit 4-7
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Mean and Maximum Relative Errors
for Temperatures and Heat Flow Rates

1.75
0.175
1.50
—0.150
- —_
= %1.25
o012 =
e S
5 = 1o
0.100 L
c
o s
@ e Eu.n
=0
S P‘:
l-'_ 0.050 0.50
0025 I I 0.25
0.000 0.00 l .

e e w -
in =4 wn =3

- wa

r =

b
=]

q;, Mean Error [%]

q;, Max Error [%]

= e - -
(=1 (e o W
w

?5 | |
o I

| |
& *
: o

-3 & & & & y & & & &
;s § & & & ¢ i s & & &
- # ‘ o : - ! g - F-a 2
K3 a 3‘96- o&F &é' S & & _-§ ol & :F“
& $ & § & é o #
& &

Figure 4-1: SteadyState Solve Setup Mean and Maximum Relative Errors Values
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Mean and Maximum Relative Errors
for Temperatures and Heat Flow Rates
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Figure 4-2: SteadyState2 Solve Setup Mean and Maximum Relative Errors Values

Open the Optimized STM 3D Component

In the directory you specified early, open the optimized STM's 3D component (.a3dcomp) file in
the Electronics Desktop application. Note the package geometry in the 3D Modeler window and
history tree, and note the assigned network boundary condition in the Project Manager.

The optimized STM can replace a detailed thermal model in a system-level simulation to reduce
mesh size and simulation duration, while yielding accurate thermal results.

Run the Extract Delphi Network Toolkit 4-9
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Project Manager o x E""‘@ Model
=] QFN_IcepakDesign1_ExportedCTM_DE || | - Solids
- IcepakDesignl_ExportedCTM_DE_1 . =-9% Hollow
Es 3D Components EIEI Sheets
- Model 5-E= Network
Héj Thermal =8=1ottom_inner
_E DelphiCTM =®=] Bottom_outer
- Monitor =
- ¢ Solar Loading
=-CF Mesh -
@ MeshOperation =
- JF Analysis - =
[ Optimetrics = Top_inner
[ Results ER=ETop outer
Ty Field Overlays @12, Coordinate Systems
(1 Definitions B8 Planes
E-¢2 Lists

To edit the STM component's junction power, select the 3D component's project in the Project
Manager. Edit the variable's power definition in the Properties window.

Project Manager a x

=3 @QFH_ICEDH kDesignl_FxportedCTM_DE_1 (3D Component)™
=g IcepakDesignl_ExportedCTM_DE_1 (SteadyState)

é 3D Components

----- £ Model

..... 7 Solar Loading
[#-FE Mesh

..... ‘@ Analysis
-8 Optimetrics

..... Results

..... ﬁ Field Qverlays
-1 Definitions

Properties o =
|| Name Value Unit | Evaluated Value
|5Q_GFN1_DieSource |1 W w
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